Problem during deployment on Laravel Forge

Hello,

As far as deployment is concerned - everything is standard. Both "npm install" and "npm run prod" commands are not throwing errors and they are passing normally. We serve the application from the public folder, and what we see is the served public/index.html.

Instead of expected result we have a bug, and it is white screen with title Metronic logo Loading... .

If possible, can you please tell us how can we convince the server to serve us what we need, from?
Is there any modification in theme setup required ?

Text formatting options
Submit
Here's a how to add some HTML formatting to your comment:
  • <pre></pre> for JS codes block
  • <pre lang="html"></pre> for HTML code block
  • <pre lang="scss"></pre> for SCSS code block
  • <pre lang="php"></pre> for PHP code block
  • <code></code> for single line of code
  • <strong></strong> to make things bold
  • <em></em> to emphasize
  • <ul><li></li></ul>  to make list
  • <ol><li></li></ol>  to make ordered list
  • <h3></h3> to make headings
  • <a></a> for links
  • <img> to paste in an image
  • <blockquote></blockquote> to quote somebody
  • happy  :)
  • shocked  :|
  • sad  :(

Replies (4)

I work with Milos, and wanted to add more details to this issue:
- the application works fine on our local machines
- the absolutely same code base is deployed on Digital Ocean without any issues, it is just Forge that is causing problems for us. Digital Ocean is serving our sign in page, and Forge is serving the Metronic logo Loading page.

Thanks,
Milan

Hi Milos,

Could you please verify if the Forge configuration can read the PHP files by default? Because you see HTML only from public/index.html is served. Probably the web server configuration does not recognize the PHP files.

Thanks

Hi Faizal,

php is served and responding. I can hit the backend through postman, and I'm getting expected responses.

Hi Faizal,

we solved it. The public folder contained index.html and index.php pages, and index.html is what was getting served. The index.html is the file that was showing the Metronic logo loading page. I deleted that file, and forge then defaulted to index.php, and now it's working.

Text formatting options
Submit
Here's a how to add some HTML formatting to your comment:
  • <pre></pre> for JS codes block
  • <pre lang="html"></pre> for HTML code block
  • <pre lang="scss"></pre> for SCSS code block
  • <pre lang="php"></pre> for PHP code block
  • <code></code> for single line of code
  • <strong></strong> to make things bold
  • <em></em> to emphasize
  • <ul><li></li></ul>  to make list
  • <ol><li></li></ol>  to make ordered list
  • <h3></h3> to make headings
  • <a></a> for links
  • <img> to paste in an image
  • <blockquote></blockquote> to quote somebody
  • happy  :)
  • shocked  :|
  • sad  :(
Text formatting options
Submit
Here's a how to add some HTML formatting to your comment:
  • <pre></pre> for JS codes block
  • <pre lang="html"></pre> for HTML code block
  • <pre lang="scss"></pre> for SCSS code block
  • <pre lang="php"></pre> for PHP code block
  • <code></code> for single line of code
  • <strong></strong> to make things bold
  • <em></em> to emphasize
  • <ul><li></li></ul>  to make list
  • <ol><li></li></ol>  to make ordered list
  • <h3></h3> to make headings
  • <a></a> for links
  • <img> to paste in an image
  • <blockquote></blockquote> to quote somebody
  • happy  :)
  • shocked  :|
  • sad  :(