Metronic 8.0.36 - Problems with Laravel version.

Hi,
I have installed Metronic 8.0.36 but, despite the composer.json it is specified that the laravel version must be 9, version 8.77.1 was installed.
I noticed this error trying to install another package, which obviously fails as it does not find Laravel 9 on the project:

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Root composer.json requires laravel / framework ^ 9.0, found laravel / framework [v9.0.0-beta.1, ..., 9.x-dev] but the package is fixed to v8.77.1 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
Problem 2
- Root composer.json requires nunomaduro / collision ^ 6.0, found nunomaduro / collision [v6.0.0, v6.1.0] but the package is fixed to v5.10.0 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
Problem 3
- Root composer.json requires bensampo / laravel-enum ^ 5.1 -> satisfiable by bensampo / laravel-enum [v5.1.0].
- bensampo / laravel-enum v5.1.0 requires illuminate / contracts ^ 9.0 -> found illuminate / contracts [v9.0.0-beta.1, ..., 9.x-dev] but these were not loaded, likely because it conflicts with another require.


Then if I try to repeat a composer install or update I get the following error:

Your requirements could not be resolved to an installable set of packages.

Problem 1
- illuminate / support [v5.6.0, ..., 5.8.x-dev] require php ^ 7.1.3 -> your php version (8.1.2) does not satisfy that requirement.
- Conclusion: don't install jackiedo / log-reader 2.1.4 (conflict analysis result)
- Conclusion: don't install jackiedo / log-reader 2.1.5 (conflict analysis result)
- Conclusion: don't install jackiedo / log-reader 2.1.7 (conflict analysis result)
- Conclusion: don't install jackiedo / log-reader 2.1.8 (conflict analysis result)
- illuminate / support [v5.1.41, ..., 5.2.x-dev] require paragonie / random_compat ~ 1.4 -> satisfiable by paragonie / random_compat [v1.4.0, ..., v1.x-dev].
- roave / security-advisories dev-latest conflicts with paragonie / random_compat v1.4.3.
- Root composer.json requires roave / security-advisories dev-latest -> satisfiable by roave / security-advisories [dev-latest].
- Conclusion: don't install laravel / framework v9.0.0-beta.2 (conflict analysis result)
- Conclusion: don't install laravel / framework v9.0.0-beta.3 (conflict analysis result)
- Conclusion: don't install laravel / framework v9.0.0-beta.4 (conflict analysis result)
- Conclusion: don't install laravel / framework v9.0.0-beta.5 (conflict analysis result)
- Conclusion: don't install laravel / framework v9.0.0 (conflict analysis result)
- Conclusion: don't install laravel / framework v9.0.1 (conflict analysis result)
- Conclusion: don't install laravel / framework v9.0.2 (conflict analysis result)
- Root composer.json requires jackiedo / log-reader ^ 2.1 -> satisfiable by jackiedo / log-reader [2.1.0, ..., 2.1.8].
- Conclusion: don't install laravel / framework v9.0.0-beta.1 (conflict analysis result)
- jackiedo / log-reader [2.1.0, ..., 2.1.1] require illuminate / support 5. * -> satisfiable by illuminate / support [v5.0.0, ..., 5.8.x-dev].
- Only one of these can be installed: illuminate / support [dev-master, v4.2.0-BETA1, ..., 4.2.x-dev, v5.0.0, ..., 5.8.x-dev, v6.0.0 , ..., 6.x-dev, v7.0.0, ..., 7.x-dev, v8.0.0, ..., 8.x-dev, v9.0.0-beta.1, ... , 9.x-dev], laravel / framework [v9.0.0-beta.1, ..., 9.x-dev]. laravel / framework replaces illuminate / support and thus cannot coexist with it.
- Root composer.json requires laravel / framework ^ 9.0 -> satisfiable by laravel / framework [v9.0.0-beta.1, ..., 9.x-dev].

Thanks in advance for your support.

Text formatting options
Submit
Here's a how to add some HTML formatting to your comment:
  • <pre></pre> for JS codes block
  • <pre lang="html"></pre> for HTML code block
  • <pre lang="scss"></pre> for SCSS code block
  • <pre lang="php"></pre> for PHP code block
  • <code></code> for single line of code
  • <strong></strong> to make things bold
  • <em></em> to emphasize
  • <ul><li></li></ul>  to make list
  • <ol><li></li></ol>  to make ordered list
  • <h3></h3> to make headings
  • <a></a> for links
  • <img> to paste in an image
  • <blockquote></blockquote> to quote somebody
  • happy  :)
  • shocked  :|
  • sad  :(

Replies (7)

Hi,

Please try to use this command to install the composer plugins.

composer install --ignore-platform-req=php --optimize-autoloader

Some of the 3rd party plugins may still not fully upgrade to Laravel 9. This should be fixed in future updates.

Thanks

Hi,
I tried but I still have the same problem.
Metronic v 8.0.36 continues to install Laravel 8.77.1 as seen below:

- Installing laravel/framework (v8.77.1): Extracting archive

Is there a fix for this ?

Thanks

Hi,

i've also tried upgrading my project to Laravel 9.

Unfortunately, many packages do not support Laravel 9 yet. I'd recommend using Laravel 8 until packages have the support for it.

Hi,

Please try to remove the vendor folder and package-lock.json file.

Thanks

Hi,
I tried again on another machine, this time windows (last time it was a Mac m1 pro with macos Monterey, php 8, node 16.14.0).
My configuration on Windows 10 is PHP 8.1.2, Node v14.17.6, Npm 7.5.6.
I copied the laravel folder of Metronic 8.0.36 to my htdocs, entered the project and ran the following command:

- composer install --ignore-platform-req = php --optimize-autoloader

This is the error generated:

No composer.lock file present. Updating dependencies to latest instead of installing from lock file. See https://getcomposer.org/install for more information.
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: don't install jackiedo / log-reader 2.1.4 (conflict analysis result)
- Conclusion: don't install jackiedo / log-reader 2.1.5 (conflict analysis result)
- Conclusion: don't install laravel / framework v9.0.1 (conflict analysis result)
- Conclusion: don't install laravel / framework v9.0.2 (conflict analysis result)
- Root composer.json requires jackiedo / log-reader ^ 2.1 -> satisfiable by jackiedo / log-reader [2.1.0, ..., 2.1.8].
- Conclusion: don't install laravel / framework v9.0.0-beta.1 (conflict analysis result)
- jackiedo / log-reader [2.1.0, ..., 2.1.1] require illuminate / support 5. * -> satisfiable by illuminate / support [v5.0.0, ..., 5.8.x-dev].
- Only one of these can be installed: illuminate / support [dev-master, v4.2.0-BETA1, ..., 4.2.x-dev, v5.0.0, ..., 5.8.x-dev, v6.0.0 , ..., 6.x-dev, v7.0.0, ..., 7.x-dev, v8.0.0, ..., 8.x-dev,
v9.0.0-beta.1, ..., 9.x-dev], laravel / framework [v9.0.0-beta.1, ..., 9.x-dev]. laravel / framework replaces illuminate / support and thus cannot coexist with it.
- Root composer.json requires laravel / framework ^ 9.0 -> satisfiable by laravel / framework [v9.0.0-beta.1, ..., 9.x-dev].

Thanks

Thanks this worked for me.

Hi,

It seems there are many 3rd party packages that do not support Laravel 9 yet. This should be fixed when the packages have the support for it soon. In the meantime, could you please use v8 instead?

These 2 plugins currently do not support Laravel 9.
- jackiedo/log-reader
- renatomarinho/laravel-page-speed

Please use below for your composer.json file.

"require": {
"anlutro/l4-settings": "^1.0",
"fideloper/proxy": "^4.4",
"fruitcake/laravel-cors": "^2.0",
"guzzlehttp/guzzle": "^7.0.1",
"jackiedo/log-reader": "^2.1",
"laravel/framework": "^8.83.1",
"laravel/socialite": "^5.2",
"laravel/tinker": "^2.5",
"renatomarinho/laravel-page-speed": "^2.0",
"spatie/laravel-activitylog": "^4.0",
"spatie/laravel-permission": "^4.0",
"yajra/laravel-datatables-buttons": "^4.10",
"yajra/laravel-datatables-oracle": "~9.0"
},
"require-dev": {
"barryvdh/laravel-ide-helper": "^2.9",
"facade/ignition": "^2.5",
"fakerphp/faker": "^1.9.1",
"laravel/breeze": "^1.0",
"laravel/sail": "^1.0.1",
"mockery/mockery": "^1.4.2",
"nunomaduro/collision": "^5.0",
"phpunit/phpunit": "^9.3.3",
"roave/security-advisories": "dev-latest"
},

Thanks

Text formatting options
Submit
Here's a how to add some HTML formatting to your comment:
  • <pre></pre> for JS codes block
  • <pre lang="html"></pre> for HTML code block
  • <pre lang="scss"></pre> for SCSS code block
  • <pre lang="php"></pre> for PHP code block
  • <code></code> for single line of code
  • <strong></strong> to make things bold
  • <em></em> to emphasize
  • <ul><li></li></ul>  to make list
  • <ol><li></li></ol>  to make ordered list
  • <h3></h3> to make headings
  • <a></a> for links
  • <img> to paste in an image
  • <blockquote></blockquote> to quote somebody
  • happy  :)
  • shocked  :|
  • sad  :(
Text formatting options
Submit
Here's a how to add some HTML formatting to your comment:
  • <pre></pre> for JS codes block
  • <pre lang="html"></pre> for HTML code block
  • <pre lang="scss"></pre> for SCSS code block
  • <pre lang="php"></pre> for PHP code block
  • <code></code> for single line of code
  • <strong></strong> to make things bold
  • <em></em> to emphasize
  • <ul><li></li></ul>  to make list
  • <ol><li></li></ol>  to make ordered list
  • <h3></h3> to make headings
  • <a></a> for links
  • <img> to paste in an image
  • <blockquote></blockquote> to quote somebody
  • happy  :)
  • shocked  :|
  • sad  :(